Mavjud Android loyihasini Eclipse-da import qilish

Mavjud Android loyihasini import qilishda men Eclipse-dan xato qilyapman.

Android requires compiler compliance level 5.0 or 6.0. Found '1.4' instead. Please use Android Tools > Fix Project Properties.

Xususiyatlarni tuzatdim va derleyici darajasini 1,6 ga o'rnatdim. Lekin men hali ham bir xil xatolarga duch kelmoqdaman. Endi nima qilishim kerak?

2
1.6 JDK-ni o'rnatdingizmi?
qo'shib qo'ydi muallif bakoyaro, manba
Yangi boshlanuvchilar uchun: Fix Project properties Android Tools'da loyiha nomiga o'ng bosish bilan topilganligini unutmang.
qo'shib qo'ydi muallif Martin, manba

3 javoblar

Quyidagi qadamlar bilan harakat qilib ko'ring. Men bugun Eclipse Indigo yordamida ishlashga muvaffaq bo'ldim

Create New Workspace -> Open SDK Manager -> Update the SDK -> restart the eclipse -> Import the project to this workspace -> right click on Project -> Android Tools -> Fix Project properties -> restart Eclipse

2
qo'shib qo'ydi
u ishlaydi - lekin bu PITA va dev muhiti o'zini o'zi tuzatishi kerak bo'lgan narsa.
qo'shib qo'ydi muallif Someone Somewhere, manba

Men uchun bu Eclipse yoki ADT xatosini ko'rib chiqadigan biror narsaga qaynatilgan: bu muammo ish joyining qaerda yaratilganligiga bog'liq!

Muayyan narsa strukturaga o'xshash bo'lganida paydo bo'lmadi: ish maydoni \ loyihasi Muammo struktura shunday bo'lganida paydo bo'ldi: workpace \ somesubfolder \ project.

Loyihaning o'ziga xos sozlamalarini belgilash (tuzatish xususiyatlarining mavjudligi) bu xato atrofida ishlash kabi ko'rinadi va ehtimol yaxshi yondashuv.

2
qo'shib qo'ydi

Doing Project -> Clean... fixed it for me.

Mening tutilishim to'xtadi, shuning uchun men workpace katalogini tozalashga muvaffaq bo'ldim. Bu erda taklif qilingan boshqa echimlar ishlamadi.

1
qo'shib qo'ydi