Tensorflow r1.0: Tensorflut talabini qondiradigan versiyani topa olmadi

Men derazadan python uchun Tensorflow 1.o ni o'rnatmoqchiman.

Bu mening tizim uchun ma'lumot.

D:\>python --version
Python 3.5.2 :: Anaconda 4.2.0 (32-bit)

D:\>pip3 --version
pip 9.0.1 from d:\web\anaconda\lib\site-packages (python 3.5)'

Ammo, men quyidagi buyruqni bajarganimda

D:\>pip3 install tensorflow
Collecting tensorflow
  Could not find a version that satisfies the requirement tensorflow (from versions: )
No matching distribution found for tensorflow

Muammo nima ekanini tushunmayapman ...

Va boshqa yo'lni sinab ko'rdim ...

Conda foydalanadigan holatda bu

(tensorflow) D:\>pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl
tensorflow-1.0.0-cp35-cp35m-win_x86_64.whl is not a supported wheel on this platform.

Qanaqa muammo?

19

6 javoblar

Men shu muammodaman.

Quyida men o'z muammomni hal qildim

pip3 install --upgrade https://storage.googleapis.com/tensorflow/mac/cpu/tensorflow-1.0.0-py3-none-any.whl
33
qo'shib qo'ydi
gpu havolasi haqida nima deyish mumkin?
qo'shib qo'ydi muallif Maksim Kniazev, manba
Bu yaxshi ishlaydi!
qo'shib qo'ydi muallif John Zhang, manba

Microsoft Windows-da TensorFlow Python 3.5 64-bitga kerak. Python 32-bitdan foydalanmoqdasiz.

29
qo'shib qo'ydi
@AshwinHegde Python 3.5ni sinab ko'rdingizmi?
qo'shib qo'ydi muallif Franck Dernoncourt, manba
Men uchun boshqa muhim nuqsonli ma'lumotlar menejer imtiyozlari bilan ishlaydigan pip setup ... buyrug'i bo'lishi kerak edi ... aks holda olti to'plami .
qo'shib qo'ydi muallif omatai, manba
Python 3.6 64-bitim bor, lekin men hali ham Windows 10 da bir xil xatoni oldim
qo'shib qo'ydi muallif Ashwin Hegde, manba
Ha! 3,5 da ishladi
qo'shib qo'ydi muallif Ashwin Hegde, manba
pitonni 3,6 dan 3,5 ga tushirdi va u o'rnatish kabi ko'rinadi. Hech qanday xato qilmaslik.
qo'shib qo'ydi muallif Swanand Pangam, manba
u men uchun ishlaydi !!! Tashakkur @FranckDernoncourt
qo'shib qo'ydi muallif Shahnaz Khan, manba

Derazalardagi Tensorfloft python 3.5 ga kerak. Anaconda da python 3.5ni yoqish uchun quyidagi amallarni bajarishingiz mumkin:

  1. See which version of python you have: conda search python
  2. If you already have python 3.5 then go to step 3 otherwise use conda create -n py35 python=3.5 anaconda to create python 3.5
  3. Activate python 3.5 using activate py35
  4. Now install tensorflow using conda install tensorflow

Agar "step4" ishlamasa, "tensorflou: to'plam topilmadi" kabi bir narsa keyin bu conda-forge kanalini yaratish va keyin step4 yordamida tensorofloga o'rnatishni harakat qilib ko'ring. Men uchun ishladi.

13
qo'shib qo'ydi
Bu bir nechta urinishlardan so'ng men uchun ishlaydigan birinchi kishi.
qo'shib qo'ydi muallif Tensigh, manba

Buni sinab ko'ring

Anaconda bilan o'rnatish

conda create --name tensorflow python=3.5
activate tensorflow
conda install jupyter
conda install scipy
pip install tensorflow
or
pip install tensorflow-gpu

Birinchi satr oxirida python = 3.5 qo'shilishi muhim, chunki u Python 3.5ni o'rnatadi.

4
qo'shib qo'ydi

Men bir xil xatoga yo'l qo'ygan edim

  1. Python 3.5ni oling
  2. Pivot versiyasini yangilash uchun
  3. ni bosing
  4. Tensorflowni o'rnatish

Men uchun ishladi

3
qo'shib qo'ydi

Men buni quyidagicha amalga oshirdim: python3 -m pip install - yangilanish tensorflou

1
qo'shib qo'ydi
Python
Python
372 ishtirokchilar

Bu guruh python dasturlash tilini muhokama qilish uchun. Iltimos, o'zingizni hurmat qiling va faqat dasturlash bo'yicha yozing. Botlar mavzusini @botlarhaqida guruhida muhokama qling! FAQ: @PyFAQ Offtopic: @python_uz_offtopic

Python offtopic group !
Python offtopic group !
150 ishtirokchilar

@python_uz gruppasining offtop gruppasi. offtop bo'lsa ham reklama mumkin emas ) Boshqa dasturlash tiliga oid gruppalar @languages_programming